HMW Simulator

Update the HL7Common version, used by the HMW Simulator, to 1.43.