All changes - 9.10.3

Bug

  • [PAM-537] The administrator should be able to update the AA index from the GUI
  • [PAM-550] h:outputLink outcome is executed at page rendering which causes unexpected behaviour

All changes - 9.10.2

Bug

  • [PAM-543] We want to keep the indexes for the CAT assigning authorities at the same value
  • [PAM-547] Even though the “Worklist” feature is disabled, the “create worklist” button still appears
  • [PAM-548] Automaton does not work in a zulu-7 environment
  • [PAM-549] When user want to add preferences for a system which already has preferences, transaction failed message is displayed

All changes - 9.10.1

Bug

  • [PAM-545] NPE is raised when generating a patient in the automate for IHE France

Dependencies

[INFO] ------------------------------------------------------------------------
[INFO] Building PatientManager 9.10.2
[INFO] ------------------------------------------------------------------------
[INFO]
[INFO] --- gazelle-plugins:1.60:check-dependencies (default-cli) @ PAMSimulator ---
Check dependencies :: All the dependencies are up to date.
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building PAMSimulator - EJB - JAR 9.10.2
[INFO] ------------------------------------------------------------------------
[INFO]
[INFO] --- gazelle-plugins:1.60:check-dependencies (default-cli) @ PAMSimulator-ejb ---
     net.ihe.gazelle                hl7v3-code-jar            jar          1.3.6          1.3.7       yes
     net.ihe.gazelle.maven                       version            ejb          1.0.3          2.0.0       yes
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building PAMSimulator - WAR 9.10.2
[INFO] ------------------------------------------------------------------------
[INFO]
[INFO] --- gazelle-plugins:1.60:check-dependencies (default-cli) @ PAMSimulator-war ---
Check dependencies :: All the dependencies are up to date.
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building PAMSimulator - EAR 9.10.2
[INFO] ------------------------------------------------------------------------
[INFO]
[INFO] --- gazelle-plugins:1.60:check-dependencies (default-cli) @ PAMSimulator-ear ---
Check dependencies :: All the dependencies are up to date.
[INFO] ------------------------------------------------------------------------

  • version:2.0.0 is to be used by applications running on widefly only
  • hl7v3-code-jar:1.3.7 has changed and we did not test yet that moving to this version does not break the HL7V3 responders

Remarks

None