All changes

Bug

  • [PROXY-183] Error when deploying proxy, jdbc driver

Improvement

Dependencies

[INFO] Scanning for projects...
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Build Order:
[INFO]
[INFO] gazelle-proxy
[INFO] gazelle-proxy-netty
[INFO] gazelle-proxy-jar
[INFO] gazelle-proxy - EJB
[INFO] gazelle-proxy - Common WAR
[INFO] gazelle-proxy-war
[INFO] gazelle-proxy - EAR
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building gazelle-proxy 4.5.0
[INFO] ------------------------------------------------------------------------
[INFO]
[INFO] --- gazelle-plugins:1.60:check-dependencies (default-cli) @ gazelle-proxy ---
Check dependencies :: All the dependencies are up to date.
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building gazelle-proxy-netty 4.5.0
[INFO] ------------------------------------------------------------------------
[INFO]
[INFO] --- gazelle-plugins:1.60:check-dependencies (default-cli) @ gazelle-proxy-netty ---
Check dependencies :: All the dependencies are up to date.
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building gazelle-proxy-jar 4.5.0
[INFO] ------------------------------------------------------------------------
[INFO]
[INFO] --- gazelle-plugins:1.60:check-dependencies (default-cli) @ gazelle-proxy-jar ---
Check dependencies :: All the dependencies are up to date.
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building gazelle-proxy - EJB 4.5.0
[INFO] ------------------------------------------------------------------------
[INFO]
[INFO] --- gazelle-plugins:1.60:check-dependencies (default-cli) @ gazelle-proxy-ejb ---
     net.ihe.gazelle.maven                       version            ejb          1.0.3          2.0.0       yes
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building gazelle-proxy - Common WAR 4.5.0
[INFO] ------------------------------------------------------------------------
[INFO]
[INFO] --- gazelle-plugins:1.60:check-dependencies (default-cli) @ gazelle-proxy-common-war ---
Check dependencies :: All the dependencies are up to date.
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building gazelle-proxy-war 4.5.0
[INFO] ------------------------------------------------------------------------
[INFO]
[INFO] --- gazelle-plugins:1.60:check-dependencies (default-cli) @ gazelle-proxy-war ---
Check dependencies :: All the dependencies are up to date.
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building gazelle-proxy - EAR 4.5.0
[INFO] ------------------------------------------------------------------------
[INFO]
[INFO] --- gazelle-plugins:1.60:check-dependencies (default-cli) @ gazelle-proxy-ear ---
Check dependencies :: All the dependencies are up to date.
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO]
[INFO] gazelle-proxy ...................................... SUCCESS [ 36.197 s]
[INFO] gazelle-proxy-netty ................................ SUCCESS [  3.798 s]
[INFO] gazelle-proxy-jar .................................. SUCCESS [  5.388 s]
[INFO] gazelle-proxy - EJB ................................ SUCCESS [  4.726 s]
[INFO] gazelle-proxy - Common WAR ......................... SUCCESS [  0.763 s]
[INFO] gazelle-proxy-war .................................. SUCCESS [  1.252 s]
[INFO] gazelle-proxy - EAR ................................ SUCCESS [  1.499 s]
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 56.359 s
[INFO] Finished at: 2018-03-01T16:27:41+01:00
[INFO] Final Memory: 63M/1461M
[INFO] ------------------------------------------------------------------------

Remarks

Use of net.ihe.gazelle.maven:version:2.0.0 is limited to applications running on Jboss8. This new version of the Gazelle Proxy has to be bound to new Gazelle SSO.