All changes

Bug

  • [SCHVAL-23] Need additional field to characterize a schematron
  • [SCHVAL-108] When Schematron contains no schematron (only XSD), then soap request from EVSClient to get schematron fails
  • [SCHVAL-118] transformUnknowns is reseted to null after calling Schematron webservice

Story

  • [SCHVAL-69] Update of the user guide on SchematronValidator
  • [SCHVAL-106] Missing line numbers and column in XSD validation report for schematron validation
  • [SCHVAL-107] Add support to XSD 1.1
  • [SCHVAL-114] XSD Validation of SVS document does not report line numbers and column numbers of error as it is done for CDA, XDW, XDS…

Improvement

  • [SCHVAL-48] we need a button on the list of manageSchematrons that allow to compile all schematrons
  • [SCHVAL-115] Add some field in the report of the Schematron Validation
  • [SCHVAL-117] Add button to select between XSD 1.0 and XSD 1.1 for schematron validation

Dependencies


Building SchematronValidator 2.1.0 ————————————————————————

— gazelle-plugins:1.55:check-dependencies (default-cli) @ SchematronValidator — Check dependencies :: All the dependencies are up to date.


Building SchematronValidator-ejb 2.1.0 ————————————————————————

— gazelle-plugins:1.55:check-dependencies (default-cli) @ SchematronValidator-ejb — Check dependencies :: All the dependencies are up to date.


Building SchematronValidator-war 2.1.0 ————————————————————————

— gazelle-plugins:1.55:check-dependencies (default-cli) @ SchematronValidator-war — Check dependencies :: All the dependencies are up to date.


Building SchematronValidator-ear 2.1.0 ————————————————————————

— gazelle-plugins:1.55:check-dependencies (default-cli) @ SchematronValidator-ear — Check dependencies :: All the dependencies are up to date.

Remarks

As the web service of Schematron Validator has been modified in this release, these tools have also been updated :

  • gazelle-tm-tools with a new release generated : 4.0.18
  • gazelle-ws-clients with a new release generated : 2.14

Thus, before deploying this Schematron Validator tool, It’s mandatory to use the next release of EVSClient, which use the tools shown above, to avoid incompatibility issues : The version 5.0.15 or ealier.