Failed

DemographicDataServer.Normal Cases.SEND_HL7_MESSAGES

Failing for the past 4 builds (Since Unstable#40 )
Took 0.14 sec.

Error Message

Failing due to failed test step

Stacktrace

<h3><b>2.5 Failed</b></h3><pre>[Not SOAP Fault] Response is a SOAP Fault
[Contains beginnin to MSH.6] Missing token [<ns2:sendHl7MessageResponse xmlns:ns2="http://ws.demographic.gazelle.ihe.net/">
         <Hl7MessageRespond><![CDATA[<?xml version="1.0" encoding="UTF-8"?>
<ACK xmlns="urn:hl7-org:v2xml">
    <MSH>
        <MSH.1>|</MSH.1>
        <MSH.2>^~\&amp;</MSH.2>
        <MSH.3>
            <HD.1>PAMSimulator</HD.1>
        </MSH.3>
        <MSH.4>
            <HD.1>IHE</HD.1>
        </MSH.4>
        <MSH.5>
            <HD.1>Gazelle</HD.1>
        </MSH.5>
        <MSH.6>
            <HD.1>IHE</HD.1>
        </MSH.6>] in Response
[Contains MSH.9] Missing token [<MSH.9>
            <MSG.1>ACK</MSG.1>
            <MSG.2>A28</MSG.2>
            <MSG.3>ACK</MSG.3>
        </MSH.9>] in Response
[Contains MSH11 to MSH] Missing token [<MSH.11>
            <PT.1>P</PT.1>
        </MSH.11>
        <MSH.12>
            <VID.1>2.5</VID.1>
        </MSH.12>
        <MSH.18>UTF-8</MSH.18>
    </MSH>
    <MSA>
        <MSA.1>AA</MSA.1>] in Response
[Contains MSA to end] Missing token [</MSA>
</ACK>]]></Hl7MessageRespond>
      </ns2:sendHl7MessageResponse>] in Response
</pre><hr/><h3><b>2.3.1 ADT^A01^ADT_A01 Failed</b></h3><pre>[Not SOAP Fault] Response is a SOAP Fault
[Contains beginnin to MSH.6] Missing token [<ns2:sendHl7MessageResponse xmlns:ns2="http://ws.demographic.gazelle.ihe.net/">
         <Hl7MessageRespond><![CDATA[<?xml version="1.0" encoding="UTF-8"?>
<ACK xmlns="urn:hl7-org:v2xml">
    <MSH>
        <MSH.1>|</MSH.1>
        <MSH.2>^~\&amp;</MSH.2>
        <MSH.3>
            <HD.1>PatientManager</HD.1>
        </MSH.3>
        <MSH.4>
            <HD.1>IHE</HD.1>
        </MSH.4>
        <MSH.5>
            <HD.1>Gazelle</HD.1>
        </MSH.5>
        <MSH.6>
            <HD.1>IHE</HD.1>
        </MSH.6>] in Response
[Contains MSH.9] Missing token [<MSH.9>
            <MSG.1>ACK</MSG.1>
            <MSG.2>A01</MSG.2>
            <MSG.3>ACK</MSG.3>
        </MSH.9>] in Response
[Contains MSH11 to MSA] Missing token [<MSH.11>
            <PT.1>P</PT.1>
        </MSH.11>
        <MSH.12>
            <VID.1>2.3.1</VID.1>
        </MSH.12>
        <MSH.18>UTF-8</MSH.18>
    </MSH>
    <MSA>
        <MSA.1>AE</MSA.1>
        <MSA.2>] in Response
</pre><hr/><h3><b>2.3.1 ADT^A04^ADT_A01 Failed</b></h3><pre>[Not SOAP Fault] Response is a SOAP Fault
[Contains beginnin to MSH.6] Missing token [<ns2:sendHl7MessageResponse xmlns:ns2="http://ws.demographic.gazelle.ihe.net/">
         <Hl7MessageRespond><![CDATA[<?xml version="1.0" encoding="UTF-8"?>
<ACK xmlns="urn:hl7-org:v2xml">
    <MSH>
        <MSH.1>|</MSH.1>
        <MSH.2>^~\&amp;</MSH.2>
        <MSH.3>
            <HD.1>PatientManager</HD.1>
        </MSH.3>
        <MSH.4>
            <HD.1>IHE</HD.1>
        </MSH.4>
        <MSH.5>
            <HD.1>Gazelle</HD.1>
        </MSH.5>
        <MSH.6>
            <HD.1>IHE</HD.1>
        </MSH.6>] in Response
[Contains MSH.9] Missing token [<MSH.9>
            <MSG.1>ACK</MSG.1>
            <MSG.2>A04</MSG.2>
            <MSG.3>ACK</MSG.3>
        </MSH.9>] in Response
[Contains MSH11 to MSA] Missing token [<MSH.11>
            <PT.1>P</PT.1>
        </MSH.11>
        <MSH.12>
            <VID.1>2.3.1</VID.1>
        </MSH.12>
        <MSH.18>UTF-8</MSH.18>
    </MSH>
    <MSA>
        <MSA.1>AE</MSA.1>
        <MSA.2>] in Response
</pre><hr/>