Uploaded image for project: 'Gazelle Security Suite'
  1. Gazelle Security Suite
  2. GSS-366

TLSClient simulator does not record messages anymore

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: 5.2.1
    • Fix Version/s: 5.3.0
    • Component/s: TLS
    • Labels:
      None
    • Sprint:
      2016 - S9
    • Account:
      Maintenance 2016 (MAINTENANCE2016)

      Description

      When sending message to an openssl server with the TLS Client simulator, Hibernate errors are raised and no messages are recorded.

      The connection is well recorded.

      See attached stack trace.

      To reproduce :
      * Launch an openssl server (bash): openssl s_server -cert 1260.pem -key 1260.key -CAfile 643.pem -Verify 2 -accept 4433 -verify_return_error -state -msg

      * In GSS start a TLS Client Simulator (any type)

      * exchange messages

      * See that no messages are recorded in the connection and errors appear in JBoss logs.

        BigPicture - Work Breakdown Structure

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                ceoche Cédric EOCHE-DUVAL
                Reporter:
                ceoche Cédric EOCHE-DUVAL
                Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:

                    Time Tracking

                    Estimated:
                    Original Estimate - 4 hours Original Estimate - 4 hours
                    4h
                    Remaining:
                    Remaining Estimate - 0 minutes
                    0m
                    Logged:
                    Time Spent - 5 hours, 30 minutes
                    5h 30m

                      Potential Duplicates