Uploaded image for project: 'SVSSimulator'
  1. SVSSimulator
  2. SVS-164

When SVS reports errors the xpath of the error is incorrect

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0.9
    • Component/s: None
    • Labels:
      None
    • Account:
      Maintenance 2016 (MAINTENANCE2016)

      Description

      Please look at this validation report :
      https://gazelle.ihe.net/EVSClient/detailedResult.seam?type=SVS&oid=1.3.6.1.4.1.12559.11.1.2.1.4.575568
      The error is reported at : /RetrieveValueSetResponse/ValueSet/ConceptList[0]/Concept[3]
      However, the error is located at
      /RetrieveValueSetResponse/ValueSet/ConceptList[0]/Concept[0]

      Fixing the issue in the XML at the xpath location /RetrieveValueSetResponse/ValueSet/ConceptList[0]/Concept[0] fixes the reported error. See the proof here : https://gazelle.ihe.net/EVSClient/detailedResult.seam?type=SVS&oid=1.3.6.1.4.1.12559.11.1.2.1.4.575576

        Attachments

          Activity

            People

            • Assignee:
              xfrancois Xavier FRANCOIS (Inactive)
              Reporter:
              epoiseau Eric Poiseau
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 5 hours, 30 minutes
                5h 30m
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 5 hours, 30 minutes
                5h 30m

                  Potential Duplicates