Uploaded image for project: 'SVSSimulator'
  1. SVSSimulator
  2. SVS-209

The SVS simulator is not using the correct wsaw:Action

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.1.3
    • Fix Version/s: 2.2.0
    • Component/s: None
    • Labels:
      None
    • Account:
      Maintenance 2018 (MAINTENANCE2018)

      Description

      The simulator is using the following wsaw:Action :
      - urn:ihe:iti:svs:2008:RetrieveValueSet
      - urn:ihe:iti:svs:2008:RetrieveValueSetResponse
      - urn:ihe:iti:svs:2008:RetrieveMultipleValueSets
      - urn:ihe:iti:svs:2008:RetrieveMultipleValueSetsResponse

      https://ehealthsuisse.ihe-europe.net/SVSSimulator-ejb/ValueSetRepository_Service/ValueSetRepository_PortType?wsdl

      According to the specification, it should be :
      - urn:ihe:iti:2008:RetrieveValueSet
      - urn:ihe:iti:2008:RetrieveValueSetResponse
      - urn:ihe:iti:2010:RetrieveMultipleValueSets
      - urn:ihe:iti:2010:RetrieveMultipleValueSetsResponse

      http://www.ihe.net/uploadedFiles/Documents/ITI/IHE_ITI_TF_Vol2b.pdf (page 367 and 275)

        Attachments

          Activity

            People

            • Assignee:
              mtoudic Malo Toudic
              Reporter:
              mtoudic Malo Toudic
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 1 hour
                1h
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 1 hour
                1h

                  Potential Duplicates